I'm on 5.03 prome-3. Should I upgrade to 6.35 PRO-B ?

Discussion in 'PSP-3000' started by Bryon15, Feb 25, 2011.

  1. Bryon15

    Bryon15 New Member

    Messages:
    46
    I need help making a big decision. I have a psp 3000 with CFW 5.03 prome-3 installed. I downgraded from 6.20 TN-B because 5.03 prome-3 had psx pops support. Overall I am very satisfied with it. It plays many psp isos, psx games, emulators and homebrew. The only problem I have with it is that it can't play psp games that require OFW 6.31 Namely DBZ tenkaichi tag team. And yes I tried patching it but it still didn't work. So should I upgrade to 6.35 pro-B since it can play psx eboots and higher firmware psp games? I'm hesitating because I don't want to lose any of the stuff my current 5.03 prome-3 can do. Please help.
  2. error

    error Banned

    Messages:
    24
    Nah don't bother prom is so much more stable and you can just wait for another patched plus 6.35 doesnt have pops support
  3. Bryon15

    Bryon15 New Member

    Messages:
    46
  4. qwerty123

    qwerty123 Elite Member

    Messages:
    751
    Bryon , You din't miss anything , you are right 6.35 PRO-B has POPS support
    Id say you stick to 5.03 Prom-3 atm
  5. Draik

    Draik Ultima [Moderator] Staff Member

    Messages:
    682
    Like everyone said, you don't need to update to PRO-B.
    It doesn't have anything new that Prom-3 doesn't have.

    But if you wanted to, you could update to try it out. & if you don't like it for some reason, you can use qwerty123's downgrading tutorial to go back to 5.03 Prom-3. (But keep in mind downgrading is a risky thing to do)
  6. Bryon15

    Bryon15 New Member

    Messages:
    46
    I thought the difference is that with 6.35 PRO-B I'd be able to play psp isos that require OFW 6.31/6.35 ? Something I can't seem to do on 5.03 prome-3
  7. error

    error Banned

    Messages:
    24
    ohh i didnt think it had pops support oh well bad website
  8. qwerty123

    qwerty123 Elite Member

    Messages:
    751
    Why dont you just patch your games using ISO TOOL ?
  9. Bryon15

    Bryon15 New Member

    Messages:
    46
    I tried using iso tool to patch DBZ tenkaichi tag team but it didn't work :( I just get a black screen.

    Also the only plugin and homebrew I use are game categories and bookr 8.1 Will they work on 6.35 PRO -B ?
  10. qwerty123

    qwerty123 Elite Member

    Messages:
    751
    Most of the Newest games out there need a fix or something and ISO TOOL doen't decrypt the Eboots completely
    have patience
  11. Gusha

    Gusha Moderator & Class Clown Staff Member

    Messages:
    6,700
    more spam from error....

    @ OP:

    5.03 PCFW with Prometheus is definately the way to go
    If you have upgraded use qwerty's guide to downgrade again - as Draik mentioned
    And stick with the 5.03 PCFW's (CFWE3.70 or GEN-C) with prometheus

    You will always come accross games that have issues on CFW so research before you go out and buy them - most compatibility issues get fixed in time
  12. Hawke101

    Hawke101 Member

    Messages:
    649
  13. krazy66

    krazy66 Member

    Messages:
    108
    Honestly, I like 6.35 PRO-B better. It has all the features of Gen (minus the buggy recovery menu) and has better psn support

Share This Page